Показать вопрос

sr.epifanov 16 1

Диалог подтверждения действия пользователем

&НаКлиенте
Процедура КомандаСпроситьУПользователя(Команда)
	
	Оповещение = Новый ОписаниеОповещения("КомандаСпроситьУПользователяЗавершение", ЭтаФорма, Неопределено);
	ТекстВопроса = "Будет выполнено некое действие. Продолжить?";
	ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
	
КонецПроцедуры

&НаКлиенте
Процедура КомандаСпроситьУПользователяЗавершение(Результат, ДополнительныеПараметры = Неопределено) Экспорт
	
	Если Результат = КодВозвратаДиалога.Нет Тогда
		Возврат;
	КонецЕсли;
	
        // Сделать что нужно
	
КонецПроцедуры
1

Рекомендации

См. также

ПоказатьВопросПользователю (БСП)

ПоказатьВопросУстановкиКомпонентыСканирования (БСП)

ПоказатьВопросЗаписиНовогоВладельца (БСП)

ПоказатьВопросОбУстановкеРасширенияРаботыСФайлами (БСП)

ПоказатьПодтверждениеЗакрытияПроизвольнойФормы (БСП)

ПоказатьОповещение (БСП)

ПоказатьПодключение (БСП)

ПоказатьОтключение (БСП)

TurboConf - расширение Конфигуратора 1С

Комментарии

prog1c
#1, 26 мая 2021 04:31

Добавьте пожалуйста в создание оповещения структуру ДополнительныеПараметры , чтобы не дописывать каждый раз


Модератору