Индикатор отчета для Обычных форм

miha 94 6 1
Процедура СформироватьОтчет(Кнопка)
    Элем = ЭлементыФормы.Добавить(Тип("Индикатор"), "Инд1", Истина);
    Элем.Верх = ЭтаФорма.Высота - 20;
    Элем.Высота = 25;
    Элем.Ширина = 150;
    Элем.ОтображатьПроценты = Истина;
    Элем.МинимальноеЗначение = 1;
    Элем.МаксимальноеЗначение = 100;
    Состояние( "Выводим данные отчета");
    
    Для сч = 1 по 100 Цикл
        Для ф=1 по 1000 Цикл
           //спим
 
        КонецЦикла;
       //ваш алгоритм обновления индикатора
 
        Элем.Значение = сч;        
        ЭтаФорма.Обновить();
    КонецЦикла;
    
    ЭлементыФормы.Удалить(Элем);
КонецПроцедуры
1

Рекомендации

См. также

Программная обработка расшифровки отчета на СКД на обычных формах

Прогресс с помощью СКД на обычных формах

РазместитьГруппуИндикатораОшибки (БСП)

Добавить элемент в обычную форму

пересчет реквизита табличной части обычной формы

ПриОпределенииПараметровГруппыИндикации (БСП)

Условное оформление на обычных формах (ОФ)

СформироватьПечатныеФормыДляБыстройПечатиОбычноеПриложение (БСП)

Раскраска строки табличной части документа (обычные формы) по условию

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Альк
#1, 20 августа 2021 11:13

Для ф=1 по 1000 Цикл
	 //спим

КонецЦикла;

Это зачем?


Модератору