Печать своей печатной формы (без использования команды)

//////////////////////////////////////////////////// Кнопка вызова печати

МассивОбъектов = Новый Массив;
МассивОбъектов.Добавить(СсылкаНаДокументИлиСправочник);
	
ПараметрыПечать = Новый Структура;
ПараметрыПечать.Вставить("ЗаголовокФормы", СсылкаНаДокументИлиСправочник);
	
УправлениеПечатьюКлиент.ВыполнитьКомандуПечати("ПУТЬ_К_МОДУЛЮ_МЕНЕДЖЕРА_ОБЪЕКТА_ПЕЧАТИ", "ИМЯ_МАКЕТА", МассивОбъектов, Неопределено, ПараметрыПечать);

//////////////////////////////////////////////////// Модуль менеджера объекта печати

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
		
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ИМЯ_МАКЕТА") Тогда		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
		КоллекцияПечатныхФорм,
		"ИМЯ_МАКЕТА",
		"СИНОНИМ_МАКЕТА",
		ПечатнаяФорма(МассивОбъектов));
	КонецЕсли;
	
КонецПроцедуры

Функция ПечатнаяФорма(МассивОбъектов)
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ТабличныйДокумент.АвтоМасштаб = Истина;
	ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ИМЯ";
	
	Макет = ПолучитьМакет("Макет");
	
	ОбластьМакета = Макет.ПолучитьОбласть("ОсновнаяОбласть");
	
	ТабличныйДокумент.Вывести(ОбластьМакета);
	
	Возврат ТабличныйДокумент;
	
КонецФункции
0

Рекомендации

См. также

Сведения о внешней обработке - Печать

ПечатьПоВнешнемуИсточнику (БСП)

ВыполнитьОткрытиеПечатнойФормы (БСП)

ОткрытьФормуНастроекПодменюПечать (БСП)

ПриПолученииКомандПечати (БСП)

ВыполнитьКомандуПечати (БСП)

ПередВыполнениемКомандыПечатиВнешнейПечатнойФормы (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору