Получить выделенные строки списка (с сохранением выделения)

&НаКлиенте
Функция ПолучитьЭлементыПоВыделеннымСтрокам(ВыбЭлемент, ПолеСсылка) Экспорт
	МассивЭлементов = Новый Массив();
	ВыдСтроки = Новый Массив();
	
	Для Каждого текСтр Из ВыбЭлемент.ВыделенныеСтроки Цикл
		ВыдСтроки.Добавить(ТекСтр);
	КонецЦикла;
	
	Для Каждого ТекВыд Из ВыдСтроки Цикл
		ВыбЭлемент.ТекущаяСтрока = ТекВыд;
		СсылкаНаЭлемент = ВыбЭлемент.ТекущиеДанные[ПолеСсылка];			
		МассивЭлементов.Добавить(СсылкаНаЭлемент);
	КонецЦикла;
	
	Для Каждого ТекВыд Из ВыдСтроки Цикл
		ВыбЭлемент.ВыделенныеСтроки.Добавить(ТекВыд);
	КонецЦикла;
	
	Возврат МассивЭлементов;
КонецФункции
0

Рекомендации

См. также

ЗапомнитьВыделенныеСтроки (БСП)

Выделенные строки

ВосстановитьВыделенныеСтроки (БСП)

Выделение текущей строки в отчете

ИзменитьВыделенные (БСП)

СкопироватьСтрокиВБуферОбмена (БСП)

ПолучитьОбъектыТаблицы_2_0_1_6 (БСП)

СтрокаПолей (БСП)

Таблица значений из списка колонок

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору