Выбор файла управляемое приложение

freelance_1C 30 1 1
&НаКлиенте
Процедура ЗагрузитьФайл(Команда)
	
	Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Диалог.Фильтр 			= НСтр("ru=’Книга Excel 97 (*.xls)|*.xls|Книга Excel 2007 (*.xlsx)|*.xlsx'");
	Диалог.Заголовок 		= НСтр("ru=’Выберите файл Excel'");
	ОповещениеЗавершения 	= Новый ОписаниеОповещения("ВыборФайлаЗавершение", ЭтотОбъект);
	
	Диалог.Показать(ОповещениеЗавершения);

КонецПроцедуры

&НаКлиенте
Процедура ВыборФайлаЗавершение(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
	
	Если ВыбранныеФайлы <> Неопределено Тогда
		
		ПутьКФайлу = ВыбранныеФайлы[0];
		
	КонецЕсли;
	
КонецПроцедуры
0
{18} Переменной ПутьКФайлу присвоено значение, но оно нигде не используется

Рекомендации

См. также

ИспользуемаяВерсияСервисаУправляющегоПриложения (БСП)

ИнтерфейсСервисаУправляющегоПриложения (БСП)

Восстановить положение окна программно

ОткрытьФормуВыбораФайлов (БСП)

Диалог выбора файла

ПроксиСервисаУправляющегоПриложения (БСП)

ПриОткрытии (БСП)

СтраницаВыбораТарифаОбслуживающейОрганизации (БСП)

ПоказатьДиалогВыбора (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору