Запрет выгрузки в КД по дате запрета редактирования

3 acsent 78 13

ПередКонвертациейОбъекта, глобальное событие

// Выгружаем документы только по списку организаций.
МетаданныеОбъекта = Метаданные.НайтиПоТипу(ТипЗнч(Источник));
Если МетаданныеОбъекта <> Неопределено
	И Метаданные.Документы.Содержит(МетаданныеОбъекта) Тогда
	
	Если МетаданныеОбъекта.Реквизиты.Найти("Организация") <> Неопределено Тогда	 
		
		ДатаЗапретаРедактирования = Параметры.ДатыЗапретаРедактирования[Источник.Организация.Код];
		Если ЗначениеЗаполнено(ДатаЗапретаРедактирования) Тогда
			
			Если Источник.Дата <= ДатаЗапретаРедактирования Тогда
				НеЗамещатьОбъектПриЗагрузке = Истина;
				ТолькоПолучитьУзелСсылки    = Истина;
			КонецЕсли;	
			
		КонецЕсли;	
		
	КонецЕсли;
	
КонецЕсли;
{12} Переменной НеЗамещатьОбъектПриЗагрузке присвоено значение, но оно нигде не используется
{13} Переменной ТолькоПолучитьУзелСсылки присвоено значение, но оно нигде не используется
FastCode Professional - быстрый поиск кода 1С

Похожие публикации

Проверка даты запрета изменения данных

Кеширование текущей строки для сравнения при окончании редактирования

Модератору