Запрет выгрузки в КД по дате запрета редактирования

acsent 84 1 14

ПередКонвертациейОбъекта, глобальное событие

// Выгружаем документы только по списку организаций.
МетаданныеОбъекта = Метаданные.НайтиПоТипу(ТипЗнч(Источник));
Если МетаданныеОбъекта <> Неопределено
	И Метаданные.Документы.Содержит(МетаданныеОбъекта) Тогда
	
	Если МетаданныеОбъекта.Реквизиты.Найти("Организация") <> Неопределено Тогда	 
		
		ДатаЗапретаРедактирования = Параметры.ДатыЗапретаРедактирования[Источник.Организация.Код];
		Если ЗначениеЗаполнено(ДатаЗапретаРедактирования) Тогда
			
			Если Источник.Дата <= ДатаЗапретаРедактирования Тогда
				НеЗамещатьОбъектПриЗагрузке = Истина;
				ТолькоПолучитьУзелСсылки    = Истина;
			КонецЕсли;	
			
		КонецЕсли;	
		
	КонецЕсли;
	
КонецЕсли;
0
{12} Переменной НеЗамещатьОбъектПриЗагрузке присвоено значение, но оно нигде не используется
{13} Переменной ТолькоПолучитьУзелСсылки присвоено значение, но оно нигде не используется

Рекомендации

См. также

ДатаЗапретаПоОписанию (БСП)

ЗапретРедактированияПредусмотрен (БСП)

ПриЗаполненииРазделовДатЗапретаИзменения (БСП)

РассчитанныеДатыЗапретаИзменения (БСП)

ОткрытьДатыЗапретаЗагрузкиДанных (БСП)

УточнитьНастройкуДатыЗапретаПриИзменении (БСП)

ОбновитьОтображениеДатыЗапретаПриИзменении (БСП)

Проверка даты запрета изменения данных

ОбновитьВерсиюДатЗапретаИзменения (БСП)

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору