Запуталась в Элементах и Объектах

Суть такова:
Есть справочник (СИЗ), в котором иерархический список(Родитель), в котором есть список номенклатуры(реквизита наименования нет)
Есть Документ, в котором есть строка, где я выбираю группу справочника(УсловияОкружающейСреды)
Также в документе есть таблица(СИЗ), которая должна выводить все значения выбранной группы по кнопке(Наименование и количество)
Наработки кода прилагаю, возможно, я где-то попутала значения и все пошло не так

&НаКлиенте
Процедура Команда3(Команда)
	ЗаполнениеТ3();		 	
	
КонецПроцедуры 
&НаСервере
Процедура ЗаполнениеТ3()
	Для Каждого Элемент из Объект.Ссылка.СИЗ.Родитель Цикл 
		
		ПоискЗначе(Элемент.УсловияОкружающейСреды, "СИЗ");	
	КонецЦикла;
КонецПроцедуры  


&НаСервере
Процедура ПоискЗначе(Родитель, СправочникПоиска)
	
	Если СправочникПоиска="СИЗ" тогда
		Запрос = Новый Запрос;
		Запрос.УстановитьПараметр("Родитель", Родитель);
		Запрос.Текст = "ВЫБРАТЬ
		|СИЗ.Ссылка КАК Ссылка	                	
		|ИЗ
		|Справочник.СИЗ КАК СИЗ
		|ГДЕ
		|СИЗ.Родитель =   &Родитель";
		Выборка = Запрос.Выполнить().Выбрать();
		Пока Выборка.Следующий() Цикл
			Если Объект.СИЗ.Количество()=0 тогда
				НоваяСтрока = Объект.СИЗ.Добавить();
				НоваяСтрока.Наименование = Выборка.Ссылка;
				НоваяСтрока.Количество = 1;            
				Продолжить;
			КонецЕсли;
			Для Каждого Элемент из Объект.СИЗ Цикл 
				Если не Элемент.Наименование = Выборка.Ссылка тогда
					Запись = Истина;
				иначе 
					
					Запись = Ложь;
					Прервать;
				КонецЕсли;
			КонецЦикла;
			Если Запись = Истина тогда
				НоваяСтрока = Объект.СИЗ.Добавить();
				НоваяСтрока.Наименование = Выборка.Ссылка;
				НоваяСтрока.Количество = 1;
			КонецЕсли;		
		КонецЦикла;	
		Объект.СИЗ.Сортировать("Наименование");
	КонецЕсли;
КонецПроцедуры
0
Орфографическая ошибка в ПоискЗначе (найдено 2): Значе

Рекомендации

См. также

ОбъектыМетаданныхСПредопределеннымиЭлементами (БСП)

ОбъектЯвляетсяГруппой (БСП)

ЭтоСсылочныеДанныеПоддерживающиеПредопределенныеЭлементы (БСП)

ОбновитьЭлементыДополнительныхРеквизитов (БСП)

ЗаполнитьНаименованиеПредопределенногоЭлементаВсеОбъектыАдресации (БСП)

ОбъектПриЧтенииНаСервере (БСП)

РазрешитьРедактированиеРеквизитовОбъекта (БСП)

ПриСозданииНаСервере (БСП)

ПереместитьЭлемент (БСП)

TurboConf - расширение Конфигуратора 1С

Ответы

Модератору