Свернуть массив

RomanVG 77 5 1
Процедура СвернутьМассив(Мас) Экспорт 
	
	ТЗ = Новый ТаблицаЗначений;
	ТЗ.Колонки.Добавить("ЗначМас");
	Для каждого ЗначМас из Мас Цикл 
		НСтрока = ТЗ.Добавить();
		НСтрока.ЗначМас = ЗначМас;
	КонецЦикла;
	ТЗ.Свернуть("ЗначМас");
	Мас.Очистить();
	Для каждого СтрТЗ из ТЗ Цикл 
		Мас.Добавить(СтрТЗ.ЗначМас);
	КонецЦикла;
	
КонецПроцедуры
0

Рекомендации

См. также

СвернутьМассив (БСП)

Свернуть табличную часть

Программно свернуть все уровни группировок табличного документа

Устанавливает текст заголовка, отображаемого, когда группа свернута

Свернуть строки в таблице значений конкатенацией

Как свернуть таблицу значений в коде, но получить не сумму, а максимум

СкопироватьМассив (БСП)

ЗначениеВМассив (БСП)

Разложить строку в массив

TurboConf - расширение Конфигуратора 1С

Комментарии

Модератору