Функция преобразует Массив из структур в ТаблицуЗначений

RomanVG 63 3 2
&НаСервереБезКонтекста
Функция ПреобразоватьМассивВТаблицуЗначений(мсДанные) 
    
    тзДанные = Новый ТаблицаЗначений;
    
    Для Каждого ЭлементМассива Из мсДанные Цикл
		
		Если тзДанные.Колонки.Количество() = 0 Тогда
            Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
                тзДанные.Колонки.Добавить(ЗначениеСтруктуры.Ключ);
            КонецЦикла;
        КонецЕсли;
        
        НоваяСтрока = тзДанные.Добавить();
        Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
            НоваяСтрока[ЗначениеСтруктуры.Ключ] = ЗначениеСтруктуры.Значение;
        КонецЦикла;
    КонецЦикла;
    
    Возврат тзДанные;
    
КонецФункции
1

Рекомендации

См. также

ТаблицаЗначенийВМассив (БСП)

ТаблицаЗначенийВМассив

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

МассивВТаблицуЗначений

СтрокаТаблицыЗначенийВСтруктуру (БСП)

Преобразовать массив структур в ТаблицуЗначений

Разложить массив по типам объектов

Преобразовать таблицу значений в массив

XML -> Структура/Соответствие (хмл в структуру/соответствие)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Комментарии

Модератору