Прочитать таблицу значений из XML

bolsun 480 6 11 10

Производит десериализацию таблицы значений из строки XML

Функция ПрочитатьТаблицуИзXML(СтрокаXML)
    
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.УстановитьСтроку(СтрокаXML);
    ТипОбъектаXDTO = ФабрикаXDTO.Тип("http://v8.1c.ru/8.1/data/core","ValueTable");
    ОбъектXDTO = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML,ТипОбъектаXDTO); 
    ОбъектXDTO.Проверить();
    
    ЧтениеXML.Закрыть();
    Возврат СериализаторXDTO.ПрочитатьXDTO(ОбъектXDTO);
   
КонецФункции
1
Орфографическая ошибка в десериализацию: десериализацию

Комментарии

markers
#1, ред. 27 февраля 2023 10:36

В БСП, используется более лучший способ, я всегда пользовался им, даже не зная о таком методе в БСП (этот код взят из БСП):

Функция ЗначениеВСтрокуXML(Значение) Экспорт
    
    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.УстановитьСтроку();
    СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Значение, НазначениеТипаXML.Явное);
    
    Возврат ЗаписьXML.Закрыть();
КонецФункции

Функция ЗначениеИзСтрокиXML(СтрокаXML) Экспорт
    
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.УстановитьСтроку(СтрокаXML);
    
    Возврат СериализаторXDTO.ПрочитатьXML(ЧтениеXML);
КонецФункции


См. также

ПрочитатьXMLВТаблицу (БСП)

ПрочитатьXMLВТаблицу

ТаблицаЗначенийВТаблицуХТМЛ

ПрочитатьТаблицуСовместимости (БСП)

Транспонировать таблицу значений

Сохранение таблицы значений в XML

Значения реквизитов, прочитанных из информационной базы для нескольких объектов

ЗначениеРеквизитаОбъекта (БСП)

Модератору