Выгрузить различные из поля коллекции

выгружает в массив поле коллекции без дублей

Функция ВыгрузитьРазличные(Коллекция,ИмяПоля)
	
	Результат = Новый Массив;
	Для каждого ТекущийЭлемент Из Коллекция Цикл
		ТекущееЗначение = ТекущийЭлемент[ИмяПоля];
		Если Результат.Найти(ТекущееЗначение) = Неопределено Тогда
			Результат.Добавить(ТекущееЗначение);
		КонецЕсли;
	КонецЦикла; 
	
	Возврат Результат;
КонецФункции
0

См. также

ИменаПолейКоллекцииПечатныхФорм (БСП)

Вывести все доступные поля СКД

Возвращает сумму значений в поле [ИмяПоля] всех элементов коллекции

Функции копирования настроек компоновки данных

ВыгрузитьЧастьФайла (БСП)

ВыгрузитьПользователейИнформационнойБазы (БСП)

Удалить недоступные отборы

ПриОпределенииНастроек (БСП)

ПрисоединитьИЗаполнитьКоллекцию (БСП)

Модератору