Использование биометрии в мобильной платформе 1С

FastCode 1504 12 22 67

Пример кода

&НаКлиенте
Функция Биометрия()
	#Если МобильноеПриложениеКлиент Тогда
		Если ТелефонПоддерживаетБиометрическийВход() Тогда
			ПоказатьВопрос(Новый ОписаниеОповещения("ТелефонПоддерживаетБиометрическийВходЗавершение", ЭтотОбъект), "Использовать биометрию для входа", РежимДиалогаВопрос.ДаНет);
		КонецЕсли;
	#КонецЕсли
КонецФункции

&НаКлиенте
Процедура ТелефонПоддерживаетБиометрическийВходЗавершение(РезультатВопроса, ДополнительныеПараметры) Экспорт
	Если РезультатВопроса = КодВозвратаДиалога.Да Тогда
		ПровестиБиометрическийВход();
	КонецЕсли;  
КонецПроцедуры

&НаКлиенте
Процедура ПровестиБиометрическийВход()
	#Если МобильноеПриложениеКлиент Тогда
		Попытка
			СпособПроверки = СпособДополнительнойПроверкиПользователя.ТолькоБиометрическая;
			
			Если ДополнительнаяПроверкаПользователя.ПоддерживаетсяПроверка(СпособПроверки) Тогда
				ДопПараметры = Новый Структура;
				ОписаниеОповещения = Новый ОписаниеОповещения("ПровестиБиометрическийВходЗавершение", ЭтотОбъект, ДопПараметры); 
				ДополнительнаяПроверкаПользователя.НачатьПроверку(СпособПроверки, "Введите код", ОписаниеОповещения);
			КонецЕсли;
		Исключение
			ЗаписьЖурналаРегистрации("Mobile", УровеньЖурналаРегистрации.Ошибка,,, ОписаниеОшибки());
		КонецПопытки;
	#КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ПровестиБиометрическийВходЗавершение(ОтмененоПользователем, ДополнительныеПараметры) Экспорт
	Попытка
		Если НЕ ОтмененоПользователем Тогда
			Если ИспользоватьБиометрию = Ложь Тогда
				УстановитьИспользоватьБиометрию(Истина);
			Иначе                      
				АвторизацияВыполнена = Истина;
				Структура = Новый Структура("ВходВыполнен", АвторизацияВыполнена);    
				ОбщегоНазначенияКлиент.ЗвукУспешногоВвода();
				ЭтаФорма.Закрыть(Структура);  
			КонецЕсли;
		КонецЕсли;  
	Исключение                                                                                       
		ЗаписьЖурналаРегистрации("Mobile", УровеньЖурналаРегистрации.Ошибка,,, ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры

&НаКлиенте
Функция ТелефонПоддерживаетБиометрическийВход()
	#Если МобильноеПриложениеКлиент Тогда
		Попытка   
			Если ДополнительнаяПроверкаПользователя.ПоддерживаетсяПроверка(СпособДополнительнойПроверкиПользователя.БиометрическаяИлиВводПароля) Тогда
				Возврат Истина;
			Иначе
				Возврат Ложь;
			КонецЕсли;
		Исключение
			ЗаписьЖурналаРегистрации("Mobile", УровеньЖурналаРегистрации.Ошибка,,, ОписаниеОшибки());
			Возврат Ложь;
		КонецПопытки;
	#КонецЕсли
КонецФункции
0
{2} Не все части функции возвращают значение

См. также

Мобильное приложение

ЭтоМобильныйКлиент (БСП)

СлужебнаяДоступноИспользованиеПолученияОбновленийПлатформы (БСП)

ИнтерактивнаяОбработкаПроверкиВерсииПлатформыПриЗапуске (БСП)

ПослеЗакрытияФормыНерекомендуемойВерсииПлатформы (БСП)

ВерсияПлатформыВЧисло (БСП)

Узнать версию платформы

Модератору