Расшифровка формы собственности организации

andrey5565 244 4 6 10

Параметр: Кратное наименование ЮрЛица (Пример: ип Картошка, ООО Лягушатник, ао Репа) Возвращаемое значение: (Пример: Индивидуальный предприниматель "Лягушонок") Учитываются регистры ХХ верхний хх нижний и Хх (если пользователь пьяный и вводит вместо ЧУП, Чуп, чуп, что то такое: ЧУп, чуП - лучше доработать функцию, мне - лень);

&НаСервереБезКонтекста
Функция ЗаполнениеНаименованияСРасшифровкой(Знач ЮридическоеНаименование)
	
	// Проверка;
	Если ЮридическоеНаименование = "" Тогда
		Возврат "";
	КонецЕсли;
	
	СтруктураРасшифровки = Новый Структура; // Ключ форма собственности  - Значение расшифровка формы соб;
	СтруктураРасшифровки.Вставить("ООО", "Общество с ограниченной ответственностью");
	СтруктураРасшифровки.Вставить("ИП", "Индивидуальный предприниматель");
	СтруктураРасшифровки.Вставить("ОАО", "Открытое акционерное общество");
	СтруктураРасшифровки.Вставить("АО", "Акционерное общество");
	СтруктураРасшифровки.Вставить("ЧУП", "Частное унитарное предприятие");
	//СтруктураРасшифровки.Вставить("", );
	
	МассивЧастей = СтрРазделить(ЮридическоеНаименование, " ", );  
	
	РасшифровкаЮрЛица = ""; 
	МассивАббревиатурЮрЛица = Новый Массив;
	
	Для каждого Часть Из МассивЧастей Цикл
		Для каждого КлючИЗначение Из СтруктураРасшифровки Цикл
			Если  Трег(Часть) = КлючИЗначение.Ключ ИЛИ НРег(Часть) = КлючИЗначение.Ключ ИЛИ ВРег(Часть) = КлючИЗначение.Ключ Тогда
				МассивАббревиатурЮрЛица.Добавить(Трег(Часть));
				МассивАббревиатурЮрЛица.Добавить(НРег(Часть));
				МассивАббревиатурЮрЛица.Добавить(ВРег(Часть));
				РасшифровкаЮрЛица = КлючИЗначение.Значение;	
			КонецЕсли;	
		КонецЦикла;
	КонецЦикла;	
	
	// чистим;
	Для каждого Аббревиатура Из МассивАббревиатурЮрЛица Цикл
		ЮридическоеНаименование = СтрЗаменить(ЮридическоеНаименование, Аббревиатура, "");
	КонецЦикла;
	ЮридическоеНаименование = СокрЛП(ЮридическоеНаименование);
	ЮридическоеНаименование = Трег(ЮридическоеНаименование);
	
	ПолноеНаименование	= РасшифровкаЮрЛица + " """ + ЮридическоеНаименование + """" ; 
	
	Возврат ПолноеНаименование;
	
КонецФункции // ()
0

См. также

ОбработкаРасшифровки (БСП)

Программная обработка расшифровки отчета на СКД на обычных формах

ФормаОтчетаОбработкаРасшифровки (БСП)

ОбработкаДополнительнойРасшифровки (БСП)

ФормаОтчетаОбработкаДополнительнойРасшифровки (БСП)

НастроитьФормуПодписанияШифрованияРасшифровки (БСП)

Заполнить первоначальные значения в форме (Организация)

ПриСозданииНаСервере (БСП)

ДополнитьДанныеОрганизацииОператораПерсональныхДанных (БСП)

Модератору