Установить элемент отбора динамического списка

andrey5565 286 5 7 10

Поможет, например, если хотите вывести "быстрые отборы" в основную форму списка прикладного объекта. В процедуре ищем в КоллекцииЭлементовПользовательскихНастроек элемент, который имеет тип = ОтборКомпоновкиДанных, и работаем с его коллекцией отборов (ЭлементОтбора.Элементы);

Процедура УстановитьЭлементОтбораДинамическогоСписка(ДинамическийСписок, ИмяПоля, ЗначениеПоля, ВидСравнения) Экспорт

Для Каждого ЭлементОтбора Из ДинамическийСписок.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
	
	Если ТипЗнч(ЭлементОтбора) = Тип("ОтборКомпоновкиДанных") Тогда
		
		ПользовательскийОтбор = ЭлементОтбора.Элементы;
		НовыйЭлементОтбора = Неопределено;
		
		Для Каждого СуществующийЭлементОтбора Из ПользовательскийОтбор Цикл
			
			Если СуществующийЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(ИмяПоля) Тогда
				НовыйЭлементОтбора = СуществующийЭлементОтбора;
				Прервать;
			КонецЕсли;	
				
		КонецЦикла;
		
		Если НовыйЭлементОтбора = Неопределено Тогда
			НовыйЭлементОтбора = ПользовательскийОтбор.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
			НовыйЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных(ИмяПоля);
		КонецЕсли;
	
		НовыйЭлементОтбора.ВидСравнения		= ВидСравнения;
		НовыйЭлементОтбора.Использование	= ЗначениеЗаполнено(ЗначениеПоля);
		НовыйЭлементОтбора.РежимОтображения	= РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
		НовыйЭлементОтбора.ПравоеЗначение	= ЗначениеПоля;			
		
	КонецЕсли;
	
КонецЦикла;

КонецПроцедуры

0

См. также

УстановитьЭлементОтбораДинамическогоСписка (БСП)

УдалитьЭлементыГруппыОтбораДинамическогоСписка (БСП)

ДобавитьОтборыВСписокФайлов (БСП)

ОтборДинамическогоСписка (БСП)

НастроитьОтборыДинамическогоСписка (БСП)

Установить отбор пользовательских настроек динамического списка

Получение данных динамического списка

УстановитьСвойстваДинамическогоСписка (БСП)

Модератору