Заполнить таблицу значений на основе строки

SeiOkami 434 5 9 9

Позволяет в коде не используя макеты заполнить ТЗ на основе текстовой таблицы с отступами

Источник: https://t.me/JuniorOneS

// Заполнить таблицу значений на основе текста
// 
// Параметры:
//  Таблица - ТаблицаЗначений
//  Текст   - Строка
Процедура ЗаполнитьТаблицуЗначенийНаОсновеТекста(Таблица, Текст)
	
	ЧислоСтрок   = СтрЧислоСтрок(Текст);
	ИменаКолонок = Новый Массив;
	Разделитель  = "|";
	
	Для НомерСтроки = 1 По ЧислоСтрок Цикл
		
		СтрокаТекста = СтрПолучитьСтроку(Текст, НомерСтроки);
		Если ПустаяСтрока(СтрокаТекста) Тогда
			Продолжить;
		КонецЕсли;
		
		ЧастиСтроки = СтрРазделить(СтрокаТекста, Разделитель, Истина);
		
		Если ЗначениеЗаполнено(ИменаКолонок) Тогда
			
			СтрокаТаблицы = Таблица.Добавить();
			Для ИндексЧасти = 0 По ЧастиСтроки.Количество()-1 Цикл
				СтрокаТаблицы[СокрЛП(ИменаКолонок[ИндексЧасти])] = СокрЛП(ЧастиСтроки[ИндексЧасти]);
			КонецЦикла;
			
		Иначе
			
			ИменаКолонок = ЧастиСтроки;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
1

Комментарии

SeiOkami
#1, 06 июля 2023 15:38


См. также

ЗаполнитьТаблицуЗначений (БСП)

ПрочитатьXMLВТаблицу

Описание строки в таблице значений

Отбор по таблице значений

Преобразовать строку таблицы значений в структуру

Заполнение "пустых" строк табличной части

СтрокаТаблицыЗначенийВСтруктуру (БСП)

ЗаполнитьНомераСтрокЗначенийДоступаПоВиду (БСП)

Удаление строк таблицы по условию

Модератору