Преобразование объекта в структуру

tejmur 16 1

Функция ОбъектВСтруктуру принимает на вход объект и возвращает структуру с данными полученными из этого объекта

Функция ОбъектВСтруктуру(ОбъектДанных)
	
	ОбъектКакСтрукутра = Новый Структура;

	СтандартныеРеквизитыОбъекта = ОбъектДанных.Метаданные().СтандартныеРеквизиты;
	Для Каждого РеквизитОбъекта Из СтандартныеРеквизитыОбъекта Цикл
		ОбъектКакСтрукутра.Вставить(РеквизитОбъекта.Имя, ОбъектДанных[РеквизитОбъекта.Имя]);	
	КонецЦикла;

	РеквизитыОбъекта = ОбъектДанных.Метаданные().Реквизиты;
	Для Каждого РеквизитОбъекта Из РеквизитыОбъекта Цикл
		ОбъектКакСтрукутра.Вставить(РеквизитОбъекта.Имя, ОбъектДанных[РеквизитОбъекта.Имя]);	
	КонецЦикла;
	
	ТабличныеЧасти = ОбъектДанных.Метаданные().ТабличныеЧасти;
	Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл 
		ТЗ = ОбъектДанных[ТабличнаяЧасть.Имя].Выгрузить();
		Массив = ОбщегоНазначения.ТаблицаЗначенийВМассив(ТЗ);
		ОбъектКакСтрукутра.Вставить(ТабличнаяЧасть.Имя, Массив);
	КонецЦикла;
	
	Возврат ОбъектКакСтрукутра;
	
КонецФункции
0

См. также

ОбъектXDTOВСтруктуру (БСП)

ОбъектXDTOИзДанныхXDTO (БСП)

Функции преобразования ЗаписьJSON

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

ДанныеXDTOИзДанныхИБ (БСП)

Работа с универсальными коллекциями данных

СкопироватьСтруктуру (БСП)

Реквизиты Объекта в Структуру

Конвертация даты из формата ISO8601 в дату 1С с учетом миллисекунд

Модератору