ИР Выделить метод

tormozit 24 1 1

Конфигуратор предоставляет команду "Выделить фрагмент" для вынесения части программного кода в отдельный метод с целью его вызова из разных мест.

Адаптер ИР предоставляет собственный вариант этой функции. Он позволяет указать для метода

  • директиву компиляции
  • асинхронность
  • экспортность
  • описание метода
  • вынесение в чистый контекст
  • тип и описание возвращаемого значения через параметр с пометкой "Это результат"

Для каждого параметра позволяет указать

  • тип вручную или рассчитать (при открытии выполняется автоматический расчет для внешних параметров)
  • описание
  • обязательность
  • значение по умолчанию
  • подачу на выход
  • подачу в возвращаемое значение (пометка "Это результат")

Допускается выделение только синтаксически корректных целостных фрагментов, т.е. в них все программные скобки должны быть парными.

Возвраты

Допускается выделение фрагментов с возвратами за счет некоторого ухудшения читаемости кода. Пример

Фрагмент с возвратами

Превращается в

Функция РассчитыватьАвтоматическиеСкидки()
	ИспользованиеСкидок = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитикиУпр(Дата);
	ТипВыхода = Неопределено;
	ПараметрВозврата = РассчитыватьАвтоматическиеСкидки1(ИспользованиеСкидок, мРассчитыватьАвтоматическиеСкидки, ТипВыхода);
	Если ТипВыхода = "Возврат" Тогда
		Возврат ПараметрВозврата;
	КонецЕсли;
КонецФункции

//.
// Параметры:
//    ИспользованиеСкидок - Неопределено - 
//    мРассчитыватьАвтоматическиеСкидки - ? - 
//    ТипВыхода - Строка - Служебный параметр для перехода после вызова метода
Функция РассчитыватьАвтоматическиеСкидки1(ИспользованиеСкидок, мРассчитыватьАвтоматическиеСкидки, ТипВыхода = Неопределено) Экспорт
	Если НЕ ЗначениеЗаполнено(ИспользованиеСкидок) Тогда
		ТипВыхода = "Возврат"; Возврат Ложь;
	КонецЕсли;	
	Если НЕ мРассчитыватьАвтоматическиеСкидки
		Или Проведен Тогда
		ТипВыхода = "Возврат"; Возврат Ложь;
	Иначе
		ТипВыхода = "Возврат"; Возврат Истина;
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
0

Еще в "TurboConf ИР"

ИР Автодополнение / контекстная подсказка

ИР Переименовать слово

ИР Открыть объект метаданных

ИР Анализ замера

ИР Форматировать текст

ИР Проверить модуль

ИР Найти последнее изменение метода

ИР Запустить толстый клиент

ИР Найти в модулях

ИР Список общих методов

Модератору