ЗначениеПеречисленияПоСинониму

9815 13 1
Функция ЗначениеПеречисленияПоСинониму(ИмяПеречисления, ЗначениеСинонимаТекст)
	
	ЭлементПеречисления = Перечисления[ИмяПеречисления].ПустаяСсылка();
	Для каждого ТекЭлемент Из Метаданные.Перечисления[ИмяПеречисления].ЗначенияПеречисления Цикл
		Если ВРег(ТекЭлемент.Синоним) = ВРег(ЗначениеСинонимаТекст) Тогда
			ЭлементПеречисления = Перечисления[ИмяПеречисления][ТекЭлемент.Имя];
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	Возврат ЭлементПеречисления;
	
КонецФункции
2
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

Комментарии

Mihuilka
#1, 27 апреля 2024 11:34

а при каких обстоятельствах такое возможно использовать?


CepeLLlka
#2, 22 мая 2024 13:38

(1) Mihuilka, я такое помню использовал при переносе движений документа "Операция" из БП 3.0 в БП 3.0 после переноса документов через обработку - "ВыгрузкаЗагрузкаXML", там по другому никак не получалось.


См. также

Значение перечисления по синониму

Имя перечисления по значению

ИмяЗначенияПеречисления (БСП)

СписокФорматов (БСП)

СловарьВидыДополнительныхОтчетовИОбработок (БСП)

ТипКонтактнойИнформации (БСП)

ТипВидаКонтактнойИнформации (БСП)

СловарьСпособыВызоваДополнительныхОтчетовИОбработок (БСП)

СинонимыДопПараметровМетодов (БСП)

Модератору