ТаблицаЗначенийВСписокСтруктур

prog1c 95 4 6

Преобразует ТаблицуЗначений в СписокЗначений (функция обратная СписокСтруктурВТаблицуЗначений)

Функция ТаблицаЗначенийВСписокСтруктур(ТаблицаЗначений)

	КолонкиТаблицы = Новый Массив;
	Для каждого Колонка Из ТаблицаЗначений.Колонки Цикл
		КолонкиТаблицы.Добавить(Колонка.Имя);
	КонецЦикла;
	СтрокаКолонок = СтрСоединить(КолонкиТаблицы, ",");
	
	СписокСтруктур = Новый СписокЗначений;
	Для каждого СтрокаТаблицыЗначений Из ТаблицаЗначений Цикл
		СтруктураСтроки = Новый Структура(СтрокаКолонок);
		ЗаполнитьЗначенияСвойств(СтруктураСтроки, СтрокаТаблицыЗначений);
		СписокСтруктур.Добавить(СтруктураСтроки);
	КонецЦикла;

	Возврат СписокСтруктур;

КонецФункции // ТаблицаЗначенийВСписокСтруктур()
0
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

См. также

Выгрузить динамический список в таблицу значений

ТаблицаЗначенийВМассив (БСП)

Преобразовать строку таблицы значений в структуру

Преобразовать массив структур в ТаблицуЗначений

СтрокаТаблицыЗначенийВСтруктуру (БСП)

Функция преобразует Массив из структур в ТаблицуЗначений

СписокСтруктурВТаблицуЗначений

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

УдалитьСтрокиТаблицыЗначений

Модератору