СписокСтруктурВТаблицуЗначений

prog1c 95 4 6

Преобразует СписокЗначений в ТаблицуЗначений (функция обратная ТаблицаЗначенийВСписокСтруктур)

Функция СписокСтруктурВТаблицуЗначений(СписокСтруктур)

	ТаблицаЗначений = Новый ТаблицаЗначений;
	ДобавлятьКолонки = Истина;
	Для каждого ЭлементСписка Из СписокСтруктур Цикл
		СтруктураСтроки = ЭлементСписка.Значение;
		Если ДобавлятьКолонки Тогда
			Для каждого ЭлементСтруктуры Из СтруктураСтроки Цикл
				ТаблицаЗначений.Колонки.Добавить(ЭлементСтруктуры.Ключ);
			КонецЦикла;
			ДобавлятьКолонки = Ложь;
		КонецЕсли;
		НоваяСтрока = ТаблицаЗначений.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, СтруктураСтроки); 
	КонецЦикла;

	Возврат ТаблицаЗначений;

КонецФункции // СписокСтруктурВТаблицуЗначений()
0
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

См. также

Выгрузить динамический список в таблицу значений

ТаблицаЗначенийВМассив (БСП)

Преобразовать строку таблицы значений в структуру

Преобразовать массив структур в ТаблицуЗначений

СтрокаТаблицыЗначенийВСтруктуру (БСП)

Функция преобразует Массив из структур в ТаблицуЗначений

ТаблицаЗначенийВСписокСтруктур

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

УдалитьСтрокиТаблицыЗначений

Модератору