МассивСтруктурВТаблицуЗначений

prog1c 95 4 6

Преобразует Массив в ТаблицуЗначений (функция обратная ТаблицаЗначенийВМассивСтруктур)

Функция МассивСтруктурВТаблицуЗначений(МассивСтруктур)

	ТаблицаЗначений = Новый ТаблицаЗначений;
	ДобавлятьКолонки = Истина;
	
	Для каждого СтруктураСтроки Из МассивСтруктур Цикл
		
		Если ДобавлятьКолонки Тогда
			Для каждого ЭлементСтруктуры Из СтруктураСтроки Цикл
				ТаблицаЗначений.Колонки.Добавить(ЭлементСтруктуры.Ключ);
			КонецЦикла;
			ДобавлятьКолонки = Ложь;
		КонецЕсли;

		НоваяСтрока = ТаблицаЗначений.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, СтруктураСтроки); 
	
	КонецЦикла;

	Возврат ТаблицаЗначений;

КонецФункции // МассивСтруктурВТаблицуЗначений()
0
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

См. также

ТаблицаЗначенийВМассив (БСП)

Преобразовать массив структур в ТаблицуЗначений

Функция преобразует Массив из структур в ТаблицуЗначений

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

ТаблицаЗначенийВМассивСтруктур

Работа с универсальными коллекциями данных

Преобразовать таблицу значений в массив

ТаблицаЗначенийВМассив

МассивВТаблицуЗначений

Модератору