ТаблицаЗначенийВМассивСтруктур

prog1c 95 4 6

Преобразует ТаблицуЗначений в Массив (функция обратная МассивСтруктурВТаблицуЗначений)

Функция ТаблицаЗначенийВМассивСтруктур(ТаблицаЗначений)

	КолонкиТаблицы = Новый Массив;
	Для каждого Колонка Из ТаблицаЗначений.Колонки Цикл
		КолонкиТаблицы.Добавить(Колонка.Имя);
	КонецЦикла;
	СтрокаКолонок = СтрСоединить(КолонкиТаблицы, ",");

	МассивСтруктур = Новый Массив;
	Для каждого СтрокаТаблицыЗначений Из ТаблицаЗначений Цикл
		СтруктураСтроки = Новый Структура(СтрокаКолонок);
		ЗаполнитьЗначенияСвойств(СтруктураСтроки, СтрокаТаблицыЗначений);
		МассивСтруктур.Добавить(СтруктураСтроки);
	КонецЦикла;

	Возврат МассивСтруктур;

КонецФункции // ТаблицаЗначенийВМассивСтруктур()
0
Заголовок публикации состоит из слитных слов. Разделите их пробелами, если это не общепринятое название и не имя собственное.

См. также

ТаблицаЗначенийВМассив (БСП)

Преобразовать массив структур в ТаблицуЗначений

Функция преобразует Массив из структур в ТаблицуЗначений

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

МассивСтруктурВТаблицуЗначений

Работа с универсальными коллекциями данных

Преобразовать таблицу значений в массив

ТаблицаЗначенийВМассив

МассивВТаблицуЗначений

Модератору