Поиск http ссылок в тексте

Функция НайтиСсылки(Текст)
	
	Ссылки = Новый Массив;
	
	НачальнаяПозицияПоиска = 1;
	НомерПоследнейПозиции = СтрДлина(Текст);
	Пока Истина Цикл
		
		Если НачальнаяПозицияПоиска > НомерПоследнейПозиции Тогда
			Прервать;
		КонецЕсли;
		
		НачальнаяПозиция = СтрНайти(Текст, "http", НаправлениеПоиска.СНачала, НачальнаяПозицияПоиска);
		Если НачальнаяПозиция > 0 Тогда
			ЧислоСимволов = 4;
			Пока Истина Цикл
				ЧислоСимволов = ЧислоСимволов + 1;
				Если (НачальнаяПозицияПоиска + ЧислоСимволов - 1 > НомерПоследнейПозиции) Или ПустаяСтрока(Прав(Сред(Текст, НачальнаяПозиция, ЧислоСимволов), 1)) Тогда
					Прервать;
				КонецЕсли;
			КонецЦикла;
			
			Ссылки.Добавить(Сред(Текст, НачальнаяПозиция, ЧислоСимволов - 1));
			НачальнаяПозицияПоиска = НачальнаяПозиция + ЧислоСимволов - 1;
		Иначе
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат Ссылки;
	
КонецФункции
0

См. также

ИзвлечьТекстИзФайлов (БСП)

ПриДобавленииИсключенийПоискаСсылок (БСП)

ИсключенияПоискаСсылок (БСП)

Модератору