Пример подключение к базе MS SQL через внешние источники данных 1С

Shemyl 1

Функция ПолучитьПараметрыСервера() Экспорт	
	
	Для каждого строкаПодключения из Объект.ПараметрыПодключения Цикл
		Если строкаПодключения.Выбор  Тогда
			ИмяСервераSQL = строкаПодключения.Server;
			ПользовательSQL = строкаПодключения.User;
			ПарольSQL = строкаПодключения.Password;
			БазаДанныхSQL = строкаПодключения.Base;
		КонецЕсли;
	КонецЦикла;

	Строка =
	"driver={SQL Server};" +
	"server="+ИмяСервераSQL+";"+
	"database="+БазаДанныхSQL+";";

	ПСБ_СтрокаСоединения = Строка;
	ПСБ_АутентификацияСтандартная = Истина;
	ПСБ_ИмяПользователя = ПользовательSQL;
	ПСБ_Пароль = ПарольSQL;
	ПСБ_СУБД = "MS SQL Server";
	ПСБ_БД = БазаДанныхSQL;
	
	СтрокаСоедененияССервером = "driver={SQL Server};" +
	"server="+ИмяСервераSQL+";"+
	"uid="+ПользовательSQL+";"+
	"pwd="+ПарольSQL+";"+
	"database="+БазаДанныхSQL+";";

	
	
	ПараметрыСервера = Новый Структура;
	
	ПараметрыСервера.Вставить("ПСБ_СтрокаСоединения", ПСБ_СтрокаСоединения);
	ПараметрыСервера.Вставить("ПСБ_АутентификацияСтандартная", ПСБ_АутентификацияСтандартная);
	ПараметрыСервера.Вставить("ПСБ_ИмяПользователя", ПСБ_ИмяПользователя);
	ПараметрыСервера.Вставить("ПСБ_Пароль", ПСБ_Пароль);
	ПараметрыСервера.Вставить("ПСБ_СУБД", ПСБ_СУБД);
	ПараметрыСервера.Вставить("ПСБ_БД", ПСБ_БД);
	ПараметрыСервера.Вставить("СтрокаСоедененияССервером", СтрокаСоедененияССервером);
	
	Возврат ПараметрыСервера;
	
	
КонецФункции

&НаСервере
Процедура ПроверитьПодключениеНаСервере()
	
	ПараметрыСервера = ПолучитьПараметрыСервера();
	ПараметрыСоединенияСБазой = Новый ПараметрыСоединенияВнешнегоИсточникаДанных;
	ПараметрыСоединенияСБазой.СтрокаСоединения = ПараметрыСервера.ПСБ_СтрокаСоединения;
	ПараметрыСоединенияСБазой.АутентификацияСтандартная = ПараметрыСервера.ПСБ_АутентификацияСтандартная;
	ПараметрыСоединенияСБазой.ИмяПользователя = ПараметрыСервера.ПСБ_ИмяПользователя;
	ПараметрыСоединенияСБазой.Пароль = ПараметрыСервера.ПСБ_Пароль;
	ПараметрыСоединенияСБазой.СУБД = ПараметрыСервера.ПСБ_СУБД;
	
	ВнешниеИсточникиДанных.ForRestPOS.УстановитьПараметрыСоединенияСеанса(ПараметрыСоединенияСБазой);
	Попытка
		ВнешниеИсточникиДанных.ForRestPOS.УстановитьСоединение();
		Сообщить("Подключение успешно!");
	Исключение
		Сообщить("Подключение не установлено!");
	КонецПопытки;

КонецПроцедуры
0
Орфографическая ошибка в СтрокаСоедененияССервером (найдено 3): Соеденения

См. также

СКД внешние источники данных

Подключение внешней обработки/отчета, пример оформления модуля объекта

ЭтоВнешнийИсточникДанных (БСП)

Подключение к базе через COM соединение и создание нового документа

ПриСохраненииНастроекПодключенияВнешнейСистемы (БСП)

ПолучитьВерсииИнтерфейсаЧерезВнешнееСоединение (БСП)

УстановитьВнешнееСоединениеСБазой (БСП)

ПрефиксИнформационнойБазыПоУмолчанию (БСП)

ПечатьПоВнешнемуИсточнику (БСП)

Модератору