АнализДоступностиФайловКлассификатораВКаталогеПослеПоискаФайлов (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторКлиент
БСП

Анализ доступности файлов классификатора каталоге после поиска файлов.

Процедура АнализДоступностиФайловКлассификатораВКаталогеПослеПоискаФайлов(НайденныеФайлы, ДополнительныеПараметры) Экспорт
	
	СтруктураФайла = Новый Структура("Существует, Имя, ИмяБезРасширения, ПолноеИмя, Путь, Расширение", Ложь);
	Если НайденныеФайлы.Количество() > 0 Тогда
		
		СтруктураФайла.Существует = Истина;
		ЗаполнитьЗначенияСвойств(СтруктураФайла, НайденныеФайлы[0]);
	КонецЕсли;
	
	Если СтруктураФайла.Существует Тогда
		ДополнительныеПараметры.Результат.ФайлыПоРегионам[ДополнительныеПараметры.КодРегиона].Добавить(СтруктураФайла.ПолноеИмя);
	Иначе
		ДополнительныеПараметры.Результат.ЕстьВсеФайлы = Ложь;
		ДополнительныеПараметры.ОтсутствующиеФайлы.Вставить(ДополнительныеПараметры.КодРегиона, ДополнительныеПараметры.ИмяФайла);
	КонецЕсли;
	
	АнализДоступностиФайловКлассификатораВКаталогеЗавершение(ДополнительныеПараметры.ИндексРегиона + 1, ДополнительныеПараметры);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

АнализДоступностиФайловКлассификатораВКаталогеЗавершение (БСП)

АнализДоступностиФайловКлассификатораВКаталоге (БСП)

ПроверитьДоступностьКомпонентыПослеПоискаКомпонентыНаПортале (БСП)

ФайлКлассификаторовПослеВыбораФайла (БСП)

КаталогФайлаПослеПолученияФайлаВРабочийКаталог (БСП)

ОбработатьФайлПослеПроверкиЭтоКаталог (БСП)

ОбработатьФайлПослеСозданияКаталога (БСП)

КаталогФайлаПослеОтветаНаВопросПолучитьФайл (БСП)

УдалитьФайлИзРабочегоКаталогаПослеУдаленияФайла (БСП)

TurboConf - расширение Конфигуратора 1С