ЗагрузитьАдресныйКлассификатор (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторКлиент
БСП

Загрузить адресный классификатор. Открывает форму загрузки классификатора.

// Открывает форму загрузки классификатора.
//
// Параметры:
//   Параметры - ПараметрыВыполненияКоманды, Структура - параметры открытия формы.
//
Процедура ЗагрузитьАдресныйКлассификатор(Параметры = Неопределено) Экспорт
	
	ПараметрыОкна = Новый Структура("Уникальность, Окно, НавигационнаяСсылка, Источник", Ложь);
	Если Параметры <> Неопределено Тогда
		ЗаполнитьЗначенияСвойств(ПараметрыОкна, Параметры);
	КонецЕсли;
	
	ПараметрыФормы = Новый Структура;
	Если ТипЗнч(Параметры) = Тип("Структура") Тогда
		Для Каждого КлючЗначение Из Параметры Цикл
			ПараметрыФормы.Вставить(КлючЗначение.Ключ, КлючЗначение.Значение);
		КонецЦикла;
	КонецЕсли;
	
	ИмяФормы = "РегистрСведений.АдресныеОбъекты.Форма.ЗагрузкаАдресногоКлассификатора";
	
	ОткрытьФорму(ИмяФормы, ПараметрыФормы,
		ПараметрыОкна.Источник,
		ПараметрыОкна.Уникальность,
		ПараметрыОкна.Окно,
		ПараметрыОкна.НавигационнаяСсылка);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

АдресныйКлассификаторЗагружен (БСП)

ОткрытьСведенияОбАдресномКлассификаторе (БСП)

ПоказатьФормуЗагрузкиАдресногоКлассификатора (БСП)

ДоступныеВерсииАдресныхСведений (БСП)

ПроверитьАдреса (БСП)

КоличествоЗагруженныхРегионов (БСП)

АдресныеОбъектыУровня (БСП)

ВыполнитьНачальноеЗаполнение (БСП)

ИсточникДанныхАдресногоКлассификатораВебСервис (БСП)

TurboConf - расширение Конфигуратора 1С