ЕстьСписокДомов (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Есть список домов. Возвращает есть ли список домов по идентификатору адресного объекта, поиск по подобию.

// Возвращает есть ли список домов по идентификатору адресного объекта, поиск по подобию.
//
// Параметры:
//     ИдентификаторАдресногоОбъекта - УникальныйИдентификатор - Родительский объект.
//
// Возвращаемое значение:
//     Булево - Истина, если есть информация о домах.
//
Функция ЕстьСписокДомов(ИдентификаторАдресногоОбъекта) Экспорт
	
	Если Не ЗначениеЗаполнено(ИдентификаторАдресногоОбъекта) Тогда 
		Возврат Ложь;
	КонецЕсли;
	
	ЗагруженныеАдресныеСведения = АдресныйКлассификаторПовтИсп.СведенияОЗагрузкеСубъектовРФ();
	Если ЗагруженныеАдресныеСведения["ИспользоватьЗагруженные"] Тогда
		
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|    ДомаЗданияСтроения.Строения КАК Строения
		|ИЗ
		|    РегистрСведений.ДомаЗданияСтроения КАК ДомаЗданияСтроения
		|ГДЕ
		|    ДомаЗданияСтроения.АдресныйОбъект = &АдресныйОбъект";
		
		Запрос.УстановитьПараметр("АдресныйОбъект", ИдентификаторАдресногоОбъекта);
		
		ДомаНайдены = НЕ Запрос.Выполнить().Пустой();
		Если ДомаНайдены Тогда
			Возврат Истина;
		КонецЕсли;
		
	КонецЕсли;
	
	Если ЗагруженныеАдресныеСведения["КлассификаторДоступен"] = Истина Тогда
		
		ТекстGETЗапроса = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку("selectHouse?&parentId=%1&limit=1",
			Строка(ИдентификаторАдресногоОбъекта));
		
		РезультатВебСервис = ВыполнитьЗапросЧерезВебСервис(ТекстGETЗапроса);
		
		Если РезультатВебСервис.Отказ Тогда
			Возврат Ложь;
		КонецЕсли;
		
		Возврат РезультатВебСервис.Данные.Количество() > 0;
		
	КонецЕсли;
	
	Возврат Ложь;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СписокДомов (БСП)

ДоменРасположенияСерверовИПП (БСП)

ПодставитьДомен (БСП)

ДоменАдресаКонтактнойИнформации (БСП)

ИдентификаторыАдреса (БСП)

АктуальныеАдресныеСведения (БСП)

ЗапросСписок (БСП)

СписокСтатусов (БСП)

ДополнитьСписок (БСП)

TurboConf - расширение Конфигуратора 1С