НаименованиеИСокращение (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Наименование сокращение. Разделяет исходный текст на наименование и сокращение.

// Разделяет исходный текст на наименование и сокращение.
// Сокращением считается последнее слово, отделенное пробельным символом.
//
// Параметры:
//     Название - Строка - Полное название, например "Москва г".
//
// Возвращаемое значение:
//     Структура - содержит поля.
//       * Наименование - Строка - Наименование, например "Москва". Если сокращение выделить не удалось, то исходное
//                                 название.
//       * Сокращение   - Строка - Сокращение, например "г". Если сокращение выделить не удалось, то пустая строка.
//
Функция НаименованиеИСокращение(Название) Экспорт
	ТекстПоиска = СокрП(Название);
	
	Позиция = СтрДлина(ТекстПоиска);
	Пока Позиция > 0 Цикл
		Если ПустаяСтрока(Сред(ТекстПоиска, Позиция, 1)) Тогда
			Прервать;
		КонецЕсли;
		Позиция = Позиция - 1;
	КонецЦикла;
	
	Результат = Новый Структура("Наименование, Сокращение");
	Если Позиция = 0 Тогда
		Результат.Наименование = ТекстПоиска;
		Результат.Сокращение   = "";
	Иначе
		Результат.Наименование = СокрП(Лев(ТекстПоиска, Позиция));
		Результат.Сокращение   = Сред(ТекстПоиска, Позиция + 1);
	КонецЕсли;
	
	Возврат Результат;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолныеНаименованияСокращений (БСП)

НаименованиеСокращение (БСП)

ПолноеНаименованиеАдресногоСокращения (БСП)

НаименованиеРегионаПоКоду (БСП)

СокращенияАдресныхОбъектов (БСП)

ПредставлениеУровняБезСокращения (БСП)

ОбработкаЧастыхСокращенийВАдресах (БСП)

СокращенияОбъектовАдресацииАдресаРФ (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз