ПолныеНаименованияСокращений (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Полные наименования сокращений. Полные наименования сокращений.

//  Полные наименования сокращений.
//
// Параметры:
//  СоответствиеСокращений - Соответствие - сокращения адреса.
//
Процедура ПолныеНаименованияСокращений(СоответствиеСокращений) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ТаблицаСокращений.Уровень КАК Уровень,
	               |	ТаблицаСокращений.Сокращение КАК Сокращение
	               |ПОМЕСТИТЬ ТаблицаСокращений
	               |ИЗ
	               |	&ТаблицаСокращений КАК ТаблицаСокращений
	               |;
	               |
	               |////////////////////////////////////////////////////////////////////////////////
	               |ВЫБРАТЬ
	               |	УровниСокращенийАдресныхСведений.Сокращение КАК Сокращение,
	               |	УровниСокращенийАдресныхСведений.Уровень КАК Уровень,
	               |	УровниСокращенийАдресныхСведений.Значение КАК Значение
	               |ИЗ
	               |	ТаблицаСокращений КАК ТаблицаСокращений
	               |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.УровниСокращенийАдресныхСведений КАК УровниСокращенийАдресныхСведений
	               |		ПО ТаблицаСокращений.Уровень = УровниСокращенийАдресныхСведений.Уровень
	               |			И (ТаблицаСокращений.Сокращение = УровниСокращенийАдресныхСведений.Сокращение)";
	
	ТаблицаСоответствиеСокращений = Новый ТаблицаЗначений;
	ТаблицаСоответствиеСокращений.Колонки.Добавить("Уровень", Новый ОписаниеТипов("Число"));
	ТаблицаСоответствиеСокращений.Колонки.Добавить("Сокращение", ОбщегоНазначения.ОписаниеТипаСтрока(30));
	Для каждого Элемент Из СоответствиеСокращений Цикл
		НоваяСтрока = ТаблицаСоответствиеСокращений.Добавить();
		НоваяСтрока.Уровень = Элемент.Ключ;
		НоваяСтрока.Сокращение = Элемент.Значение;
	КонецЦикла;
	
	Запрос.УстановитьПараметр("ТаблицаСокращений", ТаблицаСоответствиеСокращений);
	РезультатЗапроса = Запрос.Выполнить().Выбрать();
	
	Пока РезультатЗапроса.Следующий() Цикл
		СоответствиеСокращений[РезультатЗапроса.Уровень] = РезультатЗапроса.Значение;
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолноеНаименованиеАдресногоСокращения (БСП)

СокращенияАдресныхОбъектов (БСП)

НаименованиеИСокращение (БСП)

НаименованиеСокращение (БСП)

НаименованиеРегионаПоКоду (БСП)

КодРегиона (БСП)

Получить данные физического лица

ПредставлениеУровняБезСокращения (БСП)

TurboConf - расширение Конфигуратора 1С