ПроверитьНачальноеЗаполнение (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Проверить начальное заполнение. Проверяет наличие записей о регионах в регистре сведений АдресныеОбъекты и заполняет их в случае отсутствия.

// Проверяет наличие записей о регионах в регистре сведений АдресныеОбъекты и заполняет их в случае отсутствия.
//
Функция ПроверитьНачальноеЗаполнение() Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	АдресныеОбъекты.Уровень
		|ИЗ
		|	РегистрСведений.АдресныеОбъекты КАК АдресныеОбъекты
		|ГДЕ
		|	АдресныеОбъекты.Уровень = 1";
	
	РезультатЗапроса = Запрос.Выполнить().Выгрузить();
	
	Если РезультатЗапроса.Количество() = 0 Тогда
		Если ПравоДоступа("Изменение", Метаданные.РегистрыСведений.АдресныеОбъекты) Тогда
			ВыполнитьНачальноеЗаполнение();
		Иначе
			Возврат Ложь;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Истина;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НачальноеЗаполнение (БСП)

ВыполнитьНачальноеЗаполнение (БСП)

СоздатьАдминистратора (БСП)

ЗаполнитьНазначениеГруппВнешнихПользователей (БСП)

УстановитьНачальнуюДатуЗапретаИзменения (БСП)

ЗаполнитьНаименованияВидовКонтактнойИнформацииПользователя (БСП)

ЗаполнитьНаименованиеПредопределенногоЭлементаВсеОбъектыАдресации (БСП)

ЗаполнитьНаименованиеПредопределенныхГруппПользователей (БСП)

ИмяФайлаМанифеста (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз