РаспознатьАдрес (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Распознать адрес.

Функция РаспознатьАдрес(ЧастиАдреса, Представление, ВСтруктуру = Ложь) Экспорт
	
	ЗагруженныеАдресныеСведения = АдресныйКлассификаторПовтИсп.СведенияОЗагрузкеСубъектовРФ();
	
	КодРегиона = ОпределитьКодРегионаПоЧастямАдреса(ЧастиАдреса);
	
	Если ЗагруженныеАдресныеСведения.Получить("ИспользоватьЗагруженные") = Истина
		И ТипЗнч(ЗагруженныеАдресныеСведения.Получить(КодРегиона)) = Тип("Структура")
		И ЗагруженныеАдресныеСведения.Получить(КодРегиона).ИспользоватьЗагруженные Тогда
			Адрес = РаспознатьАдресЗагруженныеДанные(ЧастиАдреса);
			Если СтрСравнить(Адрес.addressType, АдресВСвободнойФорме()) <> 0 Тогда
				Возврат Адрес;
			КонецЕсли;
	ИначеЕсли ЗагруженныеАдресныеСведения.Получить("КлассификаторДоступен") = Истина Тогда
			Адрес = РаспознатьАдресВебСервис(ЧастиАдреса, Представление, ВСтруктуру);
			Возврат Адрес;
	КонецЕсли;
		
	Возврат Неопределено;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

АдресЕАЭС (БСП)

ЭтоМуниципальныйАдрес (БСП)

МуниципальныйАдрес (БСП)

ПредставлениеАдреса (БСП)

ИностранныйАдрес (БСП)

АдресСайта (БСП)

ПроверитьАдрес (БСП)

АвтоподборАдреса (БСП)

АдресИПредставление (БСП)

TurboConf - расширение Конфигуратора 1С