СведенияОРегионе (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Сведения регионе. Возвращает код региона и проверяет наличие загруженных адресных сведений по региону.

// Возвращает код региона и проверяет наличие загруженных адресных сведений по региону.
//
Функция СведенияОРегионе(НаименованиеРегиона) Экспорт
	
	Результат = Новый Структура("Загружен, КодСубъектаРФ", Ложь, Неопределено);
	СведенияОРегионе = НаименованиеИСокращение(НаименованиеРегиона);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	АдресныеОбъекты.КодСубъектаРФ КАК КодСубъектаРФ,
		|	ВЫБОР
		|		КОГДА НЕ ЗагруженныеДанные.Идентификатор ЕСТЬ NULL 
		|			ТОГДА ИСТИНА
		|		ИНАЧЕ ЛОЖЬ
		|	КОНЕЦ КАК РегионЗагружен
		|ИЗ
		|	РегистрСведений.АдресныеОбъекты КАК АдресныеОбъекты
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АдресныеОбъекты КАК ЗагруженныеДанные
		|		ПО (ЗагруженныеДанные.Уровень > 1)
		|			И АдресныеОбъекты.КодСубъектаРФ = ЗагруженныеДанные.КодСубъектаРФ
		|ГДЕ
		|	АдресныеОбъекты.Наименование = &Наименование
		|	И АдресныеОбъекты.Сокращение = &Сокращение
		|	И АдресныеОбъекты.Уровень = 1";
	
	Запрос.УстановитьПараметр("Наименование", СведенияОРегионе.Наименование);
	Запрос.УстановитьПараметр("Сокращение", СведенияОРегионе.Сокращение);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Если РезультатЗапроса.Пустой() Тогда
		Возврат Результат;
	КонецЕсли;
	
	ИнформацияОРегионе = РезультатЗапроса.Выбрать();
	
	Если ИнформацияОРегионе.Следующий() Тогда
		Результат.Загружен = ИнформацияОРегионе.РегионЗагружен;
		Результат.КодСубъектаРФ = ИнформацияОРегионе.КодСубъектаРФ;
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СведенияОЗагрузкеСубъектовРФ (БСП)

СведенияОбАдресах (БСП)

СведенияОбАдресе (БСП)

СведенияОДоступностиАдресногоКлассификатора (БСП)

ПроверитьНачальноеЗаполнение (БСП)

НаименованиеРегионаПоКоду (БСП)

КодРегионаПоНаименованию (БСП)

ОпределитьРегионПоИндексу (БСП)

КодРегиона (БСП)

TurboConf ИР адаптер 1.63