УстановитьИдентификаторыАдреса (БСП)

Автор: 1С
ОбщийМодуль.АдресныйКлассификаторСлужебный
БСП

Установить идентификаторы адреса. Локальная проверка одного адреса.

// Локальная проверка одного адреса.
//
Процедура УстановитьИдентификаторыАдреса(Адрес, Источник = "") Экспорт
	
	ЗагруженныеАдресныеСведения = АдресныйКлассификаторПовтИсп.СведенияОЗагрузкеСубъектовРФ();
	КодРегиона = АдресныйКлассификатор.КодРегионаПоНаименованию(СокрЛП(Адрес.Area + " " + Адрес.AreaType));
	
	Если ТипЗнч(КодРегиона) = Тип("Число") Тогда
		Если Источник <> "Сервис1С" И ЗагруженныеАдресныеСведения.Получить(КодРегиона) <> Неопределено
		 И ЗагруженныеАдресныеСведения.Получить(КодРегиона).ИспользоватьЗагруженные Тогда
			УстановитьИдентификаторыАдресаПоЗагруженнымДанным(Адрес);
			
				Если ЭтоГородФедеральногоЗначения(Адрес) = Истина
					И ЭтоМуниципальныйАдрес(Адрес.addressType) Тогда
						УстановитьИдентификаторыДляМуниципальногоАдреса(Адрес);
				КонецЕсли;
				
		ИначеЕсли ЗагруженныеАдресныеСведения.Получить("КлассификаторДоступен") = Истина Или Источник ="Сервис1С" Тогда
			УстановитьИдентификаторыАдресаЧерезВебСервис(Адрес);
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОпределитьИдентификаторыАдреса (БСП)

АдресПоИдентификатору (БСП)

УстановитьВнутреннийАдресМенеджераСервиса (БСП)

ИдентификаторыАдреса (БСП)

АдресЕАЭС (БСП)

РаспознатьАдрес (БСП)

ЭтоМуниципальныйАдрес (БСП)

МуниципальныйАдрес (БСП)

ПредставлениеАдреса (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз