ФормаОтчетаОбработкаДополнительнойРасшифровки (БСП)

Автор: 1С
ОбщийМодуль.АнализЖурналаРегистрацииКлиент
БСП

Форма отчета обработка дополнительной расшифровки. Обработчик дополнительной расшифровки (меню табличного документа формы отчета).

// Обработчик дополнительной расшифровки (меню табличного документа формы отчета).
//
// Параметры:
//   ФормаОтчета - ФормаКлиентскогоПриложения - Форма отчета.
//   Элемент     - ПолеФормы        - Табличный документ.
//   Расшифровка          - Передается из параметров обработчика "как есть".
//   СтандартнаяОбработка - Передается из параметров обработчика "как есть".
//
// См. также:
//   "Расширение поля формы для поля табличного документа.ОбработкаДополнительнойРасшифровки" в синтакс-помощнике.
//
Процедура ФормаОтчетаОбработкаДополнительнойРасшифровки(ФормаОтчета, Элемент, Расшифровка, СтандартнаяОбработка) Экспорт
	Если ФормаОтчета.НастройкиОтчета.ПолноеИмя <> "Отчет.АнализЖурналаРегистрации" Тогда
		Возврат;
	КонецЕсли;
	Если ТипЗнч(Элемент.ТекущаяОбласть) = Тип("РисунокТабличногоДокумента") Тогда
		Если ТипЗнч(Элемент.ТекущаяОбласть.Объект) = Тип("Диаграмма") Тогда
			СтандартнаяОбработка = Ложь;
			Возврат;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбработкаДополнительнойРасшифровки (БСП)

Программная обработка расшифровки отчета на СКД на обычных формах

ОбработкаРасшифровки (БСП)

ФормаОтчетаОбработкаРасшифровки (БСП)

Дополнительная расшифровка отчета БСП

ПриОбработкеДополнительнойРасшифровки (БСП)

ВидОбработкиДополнительныйОтчет (БСП)

ИспользуютсяДополнительныеОтчетыИОбработки (БСП)

ПриПодключенииОтчета (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз