УдалитьВопросыШаблонаАнкеты (БСП)

Автор: 1С
ОбщийМодуль.Анкетирование
БСП

Удалить вопросы шаблона анкеты. Процедура удаляет старые элементы вопроса шаблона анкеты.

// Процедура удаляет старые элементы вопроса шаблона анкеты.
Процедура УдалитьВопросыШаблонаАнкеты(СсылкаВладелец) Экспорт
	
	УстановитьПривилегированныйРежим(Истина);
	
	// Удалим старые вопросы шаблона.
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	ВопросыШаблонаАнкеты.Ссылка
	|ИЗ
	|	Справочник.ВопросыШаблонаАнкеты КАК ВопросыШаблонаАнкеты
	|ГДЕ
	|	ВопросыШаблонаАнкеты.Владелец = &Владелец";
	
	Запрос.УстановитьПараметр("Владелец",СсылкаВладелец);
	
	РезультатЗапроса = Запрос.Выполнить();
	Если Не РезультатЗапроса.Пустой() Тогда
		
		МассивСсылок = РезультатЗапроса.Выгрузить().ВыгрузитьКолонку("Ссылка");
		Для каждого ЭлементМассива Из МассивСсылок Цикл
			
			СправочникОбъект = ЭлементМассива.ПолучитьОбъект();
			Если (НЕ СправочникОбъект = Неопределено) Тогда
				СправочникОбъект.Удалить();
			КонецЕсли;
			
		КонецЦикла;
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьКодКартинкиШаблонаАнкеты (БСП)

ЗаполнитьДеревоШаблонаАнкеты (БСП)

УстановитьКорневойЭлементДереваАнкеты (БСП)

ПолучитьИмяВопроса (БСП)

ПостроениеФормыЗаполненияПоРазделу (БСП)

УдалитьФайлПослеОтветаНаВопрос (БСП)

УдалитьСодержимоеКаталогаПослеОтветаНаВопросПовторить (БСП)

ПереключитьВидимостьГруппТелаАнкеты (БСП)

ТаблицаДоступныхРеспондентуАнкет (БСП)

TurboConf - расширение Конфигуратора 1С