ЗаполнитьДеревоШаблонаАнкеты (БСП)

Автор: 1С
ОбщийМодуль.Анкетирование
БСП

Заполнить дерево шаблона анкеты. Заполняет дерево шаблона анкеты.

// Заполняет дерево шаблона анкеты.
//
// Параметры:
//  Форма                   - ФормаКлиентскогоПриложения - форма, для которой заполняется дерево.
//  ИмяДереваАнкеты         - Строка - имя реквизита формы, в котором будет содержаться дерево анкеты.
//  ШаблонАнкеты            - СправочникСсылка.ШаблоныАнкет - ссылка на шаблон анкеты, согласно которому будет
//                                                            заполнено дерево.
//  ЗаполнятьСтраницыПревью - Булево - признак, необходимо ли формировать таблицы превью табличных вопросов.
//
Процедура ЗаполнитьДеревоШаблонаАнкеты(Форма, ИмяДереваАнкеты, ШаблонАнкеты) Экспорт
	
	Если ШаблонАнкеты = Справочники.ШаблоныАнкет.ПустаяСсылка() Тогда
		Возврат;
	КонецЕсли;
	
	Результат = ВыполнитьЗапросПоВопросамШаблонаАнкеты(ШаблонАнкеты);
	Если Результат.Пустой() Тогда
		Возврат;
	КонецЕсли;
	
	ДеревоАнкетыСервер = Форма.РеквизитФормыВЗначение(ИмяДереваАнкеты);
	
	Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
	
	Если Выборка.Количество() > 0 Тогда
		ДобавитьСтрокиДереваАнкеты(Выборка,ДеревоАнкетыСервер.Строки[0],1,Форма);
	КонецЕсли;
	
	Форма.ЗначениеВРеквизитФормы(ДеревоАнкетыСервер,ИмяДереваАнкеты);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьКорневойЭлементДереваАнкеты (БСП)

СформироватьНумерациюДерева (БСП)

УдалитьВопросыШаблонаАнкеты (БСП)

УстановитьЭлементДереваРазделовАнкетыВступлениеЗаключение (БСП)

ЗаполнитьДеревоРазделов (БСП)

ПостроениеФормыЗаполненияПоРазделу (БСП)

ПолучитьИмяВопроса (БСП)

ПолучитьКодКартинкиШаблонаАнкеты (БСП)

ЗаполнитьШаблон (БСП)

TurboConf ИР адаптер 1.54