НайтиСтрокуВДанныхФормыДерево (БСП)

Автор: 1С
ОбщийМодуль.АнкетированиеКлиентСервер
БСП

Найти строку данных формы дерево. Находит первую строку в заданной колонке, с заданным значением в коллекции ДанныеФормыДерево.

// Находит первую строку в заданной колонке, с заданным значением в коллекции ДанныеФормыДерево.
Функция НайтиСтрокуВДанныхФормыДерево(ГдеИскать,Значение,Колонка,ИскатьВПодчиненных) Экспорт
	
	ЭлементыДерева = ГдеИскать.ПолучитьЭлементы();
	
	Для каждого ЭлементДерева Из ЭлементыДерева Цикл
		Если ЭлементДерева[Колонка] = Значение Тогда
			Возврат ЭлементДерева.ПолучитьИдентификатор();
		ИначеЕсли  ИскатьВПодчиненных Тогда
			НайденныйИдентификаторСтроки =  НайтиСтрокуВДанныхФормыДерево(ЭлементДерева,Значение,Колонка,ИскатьВПодчиненных);
			Если НайденныйИдентификаторСтроки >=0 Тогда
				Возврат НайденныйИдентификаторСтроки;
			КонецЕсли;
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат -1;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

Найти значение в строке

Сортировка ДанныеФормыДеревоЗначений с изменением направления

НайтиСтрокиТаблицы (БСП)

ЗаполнитьКоллекциюЭлементовДереваДанныхФормы (БСП)

ЗаполнитьДеревоРазделов (БСП)

РазвернутьУзлыДерева (БСП)

Найти заказы, количества во всех строках которых меньше либо равны нулю

ДеревоПодсистемСформировать (БСП)

Интерактивный отбор дерева значений

TurboConf ИР адаптер 1.53