УдалитьПоследниеСимволыИзСтроки (БСП)

Автор: 1С
ОбщийМодуль.АнкетированиеКлиентСервер
БСП

Удалить последние символы из строки. Удаляет из строки последние символы, если они равны подстроке удаления,

// Удаляет из строки последние символы, если они равны подстроке удаления,
// до тех пор, пока последние символы будут не равны подстроке удаления.   
//
// Параметры:
//  ВходящаяСтрока    - Строка - строка, которая будет обрабатываться.
//  ПодстрокаУдаления - Строка - подстрока, которая будет удалена из конца строки.
//  Разделитель       - Строка - если задан, то удаление происходит только в том случае, 
//                        если подстрока удаления находится целиком после разделителя.
//
// Возвращаемое значение:
//   Строка  - получившаяся в результате обработки строка.
//
Функция УдалитьПоследниеСимволыИзСтроки(ВходящаяСтрока,ПодстрокаУдаления,Разделитель = Неопределено) Экспорт
	
	Пока Прав(ВходящаяСтрока,СтрДлина(ПодстрокаУдаления)) = ПодстрокаУдаления Цикл
		
		Если Разделитель <> Неопределено Тогда
			Если СРЕД(ВходящаяСтрока,СтрДлина(ВходящаяСтрока)-СтрДлина(ПодстрокаУдаления)-СтрДлина(Разделитель),СтрДлина(Разделитель)) = Разделитель Тогда
				Возврат ВходящаяСтрока;
			КонецЕсли;
		КонецЕсли;
		ВходящаяСтрока = ЛЕВ(ВходящаяСтрока,СтрДлина(ВходящаяСтрока) - СтрДлина(ПодстрокаУдаления));
		
	КонецЦикла;
	
	Возврат ВходящаяСтрока;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УдалитьПоследнийСимволВСтроке (БСП)

УдалитьПоследнийСимвол (БСП)

УдалитьНедопустимыеСимволыXML (БСП)

УдалитьПовторяющиесяСимволы (БСП)

УдалитьНедопустимыеСимволы (БСП)

Удаление повторяющихся символов в начале или конце текста

ЗаменитьНедопустимыеСимволыXML (БСП)

ЗаменитьОдниСимволыДругими (БСП)

ПроверитьСтрокуНаЗапрещенныеСимволы (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз