Описание (БСП)

Автор: 1С
ОбщийМодуль.АсинхронноеПолучениеДанных
БСП

Описание. Возвращает описание данных логического хранилища.

// Возвращает описание данных логического хранилища.
//
// Параметры:
//  ИдентификаторХранилища - Строка - идентификатор логического хранилища.
//  ИдентификаторДанных    - Строка - идентификатор данных хранилища.
// 
// Возвращаемое значение:
//   - Структура - описание данных, которые можно получить.
//       - ИмяФайла - Строка - имя файла описания.
//       - Размер - Число - размер файла в байтах.
//       - Данные - ДвоичныеДанные - двоичные данные файла описания задания.
//
Функция Описание(ИдентификаторХранилища, ИдентификаторДанных) Экспорт
    
    Словарь = АсинхронноеПолучениеДанныхСловарь;
    Если ВРег(ИдентификаторДанных) = ВРег(Словарь.ЗапросСписок()) Тогда
        СписокДоступныхВозвращаемыхДанных = Новый Массив;
        ДоступныеВозвращаемыеДанные = ДоступныеВозвращаемыеДанные();
        Для Каждого Элемент Из ДоступныеВозвращаемыеДанные Цикл
            ОписаниеВозвращаемыхДанных = Новый Структура;
            ОписаниеВозвращаемыхДанных.Вставить("id", Элемент.Ключ);
            ОписаниеВозвращаемыхДанных.Вставить("name", Элемент.Значение.Наименование);
            ОписаниеВозвращаемыхДанных.Вставить("description", Элемент.Значение.Описание);
            ОписаниеВозвращаемыхДанных.Вставить("result_types", Элемент.Значение.ТипыРезультата);
            СписокДоступныхВозвращаемыхДанных.Добавить(ОписаниеВозвращаемыхДанных);            
        КонецЦикла; 
        Данные = РаботаВМоделиСервисаБТС.СтрокаИзСтруктурыJSON(СписокДоступныхВозвращаемыхДанных);
        Описание = Новый Структура;
        Описание.Вставить("ИмяФайла", СтрШаблон("%1.%2", Словарь.ЗапросСписок(), Словарь.ТипJSON()));
        Описание.Вставить("Данные", ПолучитьДвоичныеДанныеИзСтроки(Данные));
        Описание.Вставить("Размер", Описание.Данные.Размер());
        Возврат Описание;
    КонецЕсли; 
    
    Возврат Неопределено;
    
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

Описание (БСП)

ОписанияКонтактов (БСП)

ОписаниеДанныхОрганизации (БСП)

ОписаниеДанныхСубъекта (БСП)

ОписаниеТипаВсеСсылки (БСП)

TurboConf ИР адаптер 1.44