ОтключитьАвтоматическуюСинхронизациюДанныхСПриложениемВИнтернете (БСП)

Автор: 1С
ОбщийМодуль.АвтономнаяРаботаСлужебный
БСП

Отключить автоматическую синхронизацию данных приложением интернете. Для внутреннего использования

// Для внутреннего использования
// 
Процедура ОтключитьАвтоматическуюСинхронизациюДанныхСПриложениемВИнтернете(Источник) Экспорт
	
	Если Не ОбщегоНазначения.РазделениеВключено() Тогда
		
		ОтключитьАвтоматическуюСинхронизацию = Ложь;
		
		Для Каждого СтрокаНабора Из Источник Цикл
			
			Если СтрокаНабора.ВидТранспортаСообщенийОбменаПоУмолчанию = Перечисления.ВидыТранспортаСообщенийОбмена.WS
				И Не СтрокаНабора.WSЗапомнитьПароль Тогда
				
				ОтключитьАвтоматическуюСинхронизацию = Истина;
				Прервать;
				
			КонецЕсли;
			
		КонецЦикла;
		
		Если ОтключитьАвтоматическуюСинхронизацию Тогда
			
			УстановитьПривилегированныйРежим(Истина);
			
			РегламентныеЗаданияСервер.УстановитьИспользованиеРегламентногоЗадания(
				Метаданные.РегламентныеЗадания.СинхронизацияДанныхСПриложениемВИнтернете, Ложь);
			
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтключитьАвтоматическуюСинхронизациюДанныхПриЗаписи (БСП)

МодульПомощникНастройкиСинхронизацииДанныхМеждуПриложениямиВИнтернете (БСП)

ВключитьОтключитьАвтоматическуюУстановкуИсправлений (БСП)

СинхронизироватьДанныеСПриложениемВИнтернетеПриЗавершенииРаботы (БСП)

СинхронизироватьДанныеСПриложениемВИнтернетеПриНачалеРаботы (БСП)

ПодключениеИнтернетПоддержкиЗавершениеАвтоматическаяУстановкаИсправлений (БСП)

НовоеОписаниеСсылкиСайтаДляПубликацииПриложенийЧерезИнтернет (БСП)

ОтключенаЛогикаНачалаРаботыСистемы (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз