ПередНачаломРаботыСистемы (БСП)

Автор: 1С
ОбщийМодуль.АвтономнаяРаботаСлужебныйКлиент
БСП

Перед началом работы системы. Проверяет настройку автономного рабочего места и уведомляет об ошибке.

// Проверяет настройку автономного рабочего места и уведомляет об ошибке.
Процедура ПередНачаломРаботыСистемы(Параметры) Экспорт
	
	ПараметрыКлиента = СтандартныеПодсистемыКлиент.ПараметрыРаботыКлиентаПриЗапуске();
	
	Если ПараметрыКлиента.Свойство("ПерезапуститьПослеНастройкиАвтономногоРабочегоМеста") Тогда
		Параметры.Отказ = Истина;
		Параметры.Перезапустить = Истина;
		Возврат;
	КонецЕсли;
	
	Если НЕ ПараметрыКлиента.Свойство("ОшибкаПриНастройкеАвтономногоРабочегоМеста") Тогда
		Возврат;
	КонецЕсли;
	
	Параметры.Отказ = Истина;
	Параметры.ИнтерактивнаяОбработка = Новый ОписаниеОповещения(
		"ИнтерактивнаяОбработкаПриПроверкеНастройкиАвтономногоРабочегоМеста", ЭтотОбъект);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередНачаломРаботыСистемы (БСП)

ПередНачаломРаботыСистемы3 (БСП)

ПередНачаломРаботыСистемы4 (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз