ФормаЗадачиОбработкаОповещения (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиКлиент
БСП

Форма задачи обработка оповещения. Стандартный обработчик оповещения для форм выполнения задач.

// Стандартный обработчик оповещения для форм выполнения задач.
//  Для вызова из обработчика события формы ОбработкаОповещения.
//
// Параметры:
//  Форма      - ФормаКлиентскогоПриложения - Форма выполнения задачи.
//  ИмяСобытия - Строка           - Имя события.
//  Параметр   - Произвольный     - Параметр события.
//  Источник   - Произвольный     - Источник события.
//
Процедура ФормаЗадачиОбработкаОповещения(Форма, ИмяСобытия, Параметр, Источник) Экспорт
	
	Если ИмяСобытия = "Запись_ЗадачаИсполнителя" 
		И НЕ Форма.Модифицированность 
		И (Источник = Форма.Объект.Ссылка ИЛИ (ТипЗнч(Источник) = Тип("Массив") 
		И Источник.Найти(Форма.Объект.Ссылка) <> Неопределено)) Тогда
		Если Параметр.Свойство("Перенаправлена") Тогда
			Форма.Закрыть();
		Иначе
			Форма.Прочитать();
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбработкаОповещения (БСП)

ОбработкаОповещенияФормы (БСП)

ПослеЗавершенияСеанса (БСП)

ОбработкаОповещенияФормыСписка (БСП)

ЗавершитьНастройкуРазрешенийНаИспользованиеВнешнихРесурсов (БСП)

ПрерватьНастройкуРазрешенийНаИспользованиеВнешнихРесурсов (БСП)

ОбработкаОповещенияИзмененияФлажкаИспользоватьПоиск (БСП)

TurboConf - расширение Конфигуратора 1С