ПринятьЗадачиКИсполнению (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиКлиент
БСП

Принять задачи исполнению. Отмечает указанные задачи как принятые к исполнению.

// Отмечает указанные задачи как принятые к исполнению.
//
// Параметры:
//  МассивЗадач - Массив - массив ссылок на задачи.
//
Процедура ПринятьЗадачиКИсполнению(Знач МассивЗадач) Экспорт
	
	БизнесПроцессыИЗадачиВызовСервера.ПринятьЗадачиКИсполнению(МассивЗадач);
	Если МассивЗадач.Количество() = 0 Тогда
		ПоказатьПредупреждение(,НСтр("ru = 'Команда не может быть выполнена для указанного объекта.'"));
		Возврат;
	КонецЕсли;
	
	ТипЗначенияЗадачи = Неопределено;
	Для каждого Задача Из МассивЗадач Цикл
		Если ТипЗнч(Задача) <> Тип("СтрокаГруппировкиДинамическогоСписка") Тогда 
			ТипЗначенияЗадачи = ТипЗнч(Задача);
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Если ТипЗначенияЗадачи <> Неопределено Тогда
		ОповеститьОбИзменении(ТипЗначенияЗадачи);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПринятьЗадачиКИсполнению (БСП)

ПринятьЗадачуКИсполнению (БСП)

ОтменитьПринятиеЗадачКИсполнению (БСП)

ОтменитьПринятиеЗадачиКИсполнению (БСП)

ОбновитьДоступностьКомандПринятияКИсполнению (БСП)

РежимИсполненияВнешнегоМодуля (БСП)

Сгибы листка (задача с собеседования)

ЗаполнитьОтветственногоЗаКонтрольИсполнения (БСП)

TurboConf - расширение Конфигуратора 1С