СписокЗадачПередНачаломДобавления (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиКлиент
БСП

Список задач перед началом добавления. Стандартный обработчик ПередНачаломДобавления для списков задач.

// Стандартный обработчик ПередНачаломДобавления для списков задач.
//  Для вызова из обработчика события таблицы формы ПередНачаломДобавления.
//
// Параметры:
//  Форма        - ФормаКлиентскогоПриложения - Форма задачи.
//  Элемент      - Произвольный - Элементы таблицы формы.
//  Отказ        - Булево - Признак отказа от добавления объекта. Если в теле процедуры-обработчика установить данному
//                          параметру значение Истина, то добавление объекта выполнено не будет.
//  Копирование  - Булево - Определяет режим копирования. Если установлено Истина, то происходит копирование строки. 
//  Родитель     - Неопределено, СправочникСсылка, ПланСчетовСсылка - Ссылка на элемент, который будет использован при
//                                                                    добавлении в качестве родителя.
//  Группа       - Булево - Признак добавления группы. Истина - будет добавлена группа. 
//
Процедура СписокЗадачПередНачаломДобавления(Форма, Элемент, Отказ, Копирование, Родитель, Группа) Экспорт
	
	Если Копирование Тогда
		Задача = Элемент.ТекущаяСтрока;
		Если НЕ ЗначениеЗаполнено(Задача) Тогда
			Возврат;
		КонецЕсли;
		ПараметрыФормы = Новый Структура("Основание", Задача);
	КонецЕсли;
	СоздатьЗадание(Форма, ПараметрыФормы);
	Отказ = Истина;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СписокПередНачаломДобавления (БСП)

ВидыДоступаПередНачаломДобавления (БСП)

ПередДобавлениемКомандПечати (БСП)

ПередНачаломРаботыСистемы (БСП)

Переключатель активной задачи

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз