ДатаОтложенногоСтартаПроцесса (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиСервер
БСП

Дата отложенного старта процесса. Возвращает дату старта отложенного бизнес-процесса в том случае, когда БизнесПроцесс

// Возвращает дату старта отложенного бизнес-процесса в том случае, когда БизнесПроцесс
// ожидает отложенного старта. В противном случае возвращает пустую дату.
//
// Параметры:
//  БизнесПроцесс - БизнесПроцессСсылка -Бизнес процесс для которого требуется получить дату отложенного старта.
// 
// Возвращаемое значение:
//  Дата - Дата отложенного старта.
//
Функция ДатаОтложенногоСтартаПроцесса(БизнесПроцесс) Экспорт

	ДатаОтложенногоСтарта = '00010101';
	
	Настройка = ПараметрыОтложенногоПроцесса(БизнесПроцесс);
	
	Если Настройка = Неопределено Тогда
		Возврат ДатаОтложенногоСтарта;
	КонецЕсли;
	
	Если Настройка.Состояние = ПредопределенноеЗначение("Перечисление.СостоянияПроцессовДляЗапуска.ГотовКСтарту") Тогда
		ДатаОтложенногоСтарта = Настройка.ДатаОтложенногоСтарта;
	КонецЕсли;
	
	Возврат ДатаОтложенногоСтарта;

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтключитьОтложенныйСтартПроцесса (БСП)

СтартоватьОтложенныйПроцесс (БСП)

ДобавитьПроцессДляОтложенногоСтарта (БСП)

НастроитьОтложенныйСтарт (БСП)

СтартОтложенныхПроцессов (БСП)

ПараметрыОтложенногоПроцесса (БСП)

ВыполнитьОтложенноеОбновление (БСП)

ДатаЗавершенияБизнесПроцесса (БСП)

ПроверитьНомерБизнесПроцессаПоДате (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз