ОтключитьОтложенныйСтартПроцесса (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиСервер
БСП

Отключить отложенный старт процесса. Отключает отложенный старт процесса.

// Отключает отложенный старт процесса.
//
// Параметры:
//  Процесс - БизнесПроцессСсылка -Бизнес-процесс, у которого требуется отключить отложенный старт.
//
Процедура ОтключитьОтложенныйСтартПроцесса(Процесс) Экспорт
	
	НастройкаСтарта = ПараметрыОтложенногоПроцесса(Процесс);
	
	Если НастройкаСтарта = Неопределено Тогда // Процесс не ожидает старта.
		Возврат;
	КонецЕсли;
	
	Если НастройкаСтарта.Состояние = ПредопределенноеЗначение("Перечисление.СостоянияПроцессовДляЗапуска.ГотовКСтарту") Тогда
		НаборЗаписей = РегистрыСведений.ПроцессыДляЗапуска.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.БизнесПроцесс.Установить(Процесс);
		НаборЗаписей.Записать();
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ДобавитьПроцессДляОтложенногоСтарта (БСП)

СтартоватьОтложенныйПроцесс (БСП)

НастроитьОтложенныйСтарт (БСП)

ДатаОтложенногоСтартаПроцесса (БСП)

СтартОтложенныхПроцессов (БСП)

ПараметрыОтложенногоПроцесса (БСП)

ВыполнитьОтложенноеОбновление (БСП)

НачатьОбновлениеКоманд (БСП)

ОтключитьНебезопасноеСодержимое (БСП)

TurboConf 6 - расширение Конфигуратора 1С