ПараметрыОтложенногоПроцесса (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиСервер
БСП

Параметры отложенного процесса. Возвращает сведения о запуске для процесса.

// Возвращает сведения о запуске для процесса.
//
// Параметры:
//  Процесс - БизнесПроцессСсылка -Бизнес процесс у которого требуется получить сведения о запуске.
// 
// Возвращаемое значение:
//  - Неопределено - возвращается, если сведений нет.
//  - Структура - Если есть:
//     * БизнесПроцесс - БизнесПроцессСсылка.
//     * ДатаОтложенногоСтарта - ДатаИВремя.
//     * Состояние - ПеречислениеСсылка.СостоянияПроцессовДляЗапуска.
//     * ПричинаОтменыСтарта - Строка - причина отмены старта.
//
Функция ПараметрыОтложенногоПроцесса(Процесс) Экспорт
	
	Результат = Неопределено;
	
	Если Не ЗначениеЗаполнено(Процесс) Тогда
		Возврат Результат;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ПроцессыДляЗапуска.БизнесПроцесс,
		|	ПроцессыДляЗапуска.ДатаОтложенногоСтарта,
		|	ПроцессыДляЗапуска.Состояние,
		|	ПроцессыДляЗапуска.ПричинаОтменыСтарта
		|ИЗ
		|	РегистрСведений.ПроцессыДляЗапуска КАК ПроцессыДляЗапуска
		|ГДЕ
		|	ПроцессыДляЗапуска.БизнесПроцесс = &БизнесПроцесс";
	Запрос.УстановитьПараметр("БизнесПроцесс", Процесс);
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		Результат = Новый Структура;
		Результат.Вставить("БизнесПроцесс", Выборка.БизнесПроцесс);
		Результат.Вставить("ДатаОтложенногоСтарта", Выборка.ДатаОтложенногоСтарта);
		Результат.Вставить("Состояние", Выборка.Состояние);
		Результат.Вставить("ПричинаОтменыСтарта", Выборка.ПричинаОтменыСтарта);
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтключитьОтложенныйСтартПроцесса (БСП)

ДобавитьПроцессДляОтложенногоСтарта (БСП)

СтартоватьОтложенныйПроцесс (БСП)

НастроитьОтложенныйСтарт (БСП)

ВыполнитьОтложенноеОбновление (БСП)

ДатаОтложенногоСтартаПроцесса (БСП)

СтартОтложенныхПроцессов (БСП)

ПараметрыОтложенногоОбработчикаОбновления (БСП)

ЗаписатьПараметрыОтложенногоОбработчикаОбновления (БСП)

TurboConf - расширение Конфигуратора 1С