КоличествоНевыполненныхЗадачБизнесПроцессов (БСП)

Автор: 1С
ОбщийМодуль.БизнесПроцессыИЗадачиВызовСервера
БСП

Количество невыполненных задач бизнес процессов. Возвращает число невыполненных задач по указанным бизнес-процессам.

// Возвращает число невыполненных задач по указанным бизнес-процессам.
//
Функция КоличествоНевыполненныхЗадачБизнесПроцессов(БизнесПроцессы) Экспорт
	
	КоличествоЗадач = 0;
	
	Для каждого БизнесПроцесс Из БизнесПроцессы Цикл
		
		Если ТипЗнч(БизнесПроцесс) = Тип("СтрокаГруппировкиДинамическогоСписка") Тогда
			Продолжить;
		КонецЕсли;
		
		КоличествоЗадач = КоличествоЗадач + КоличествоНевыполненныхЗадачБизнесПроцесса(БизнесПроцесс);
		
	КонецЦикла;
		
	Возврат КоличествоЗадач;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

КоличествоНевыполненныхЗадачБизнесПроцесса (БСП)

ВыбратьБизнесПроцессыВедущейЗадачи (БСП)

БизнесПроцессыВедущейЗадачи (БСП)

БизнесПроцессыГлавнойЗадачи (БСП)

ПриПометкеУдаленияЗадачи (БСП)

ЗаполнитьГлавнуюЗадачу (БСП)

ПриЗаполненииГлавнойЗадачиБизнесПроцесса (БСП)

УстановитьПометкуУдаленияЗадач (БСП)

ОткрытьБизнесПроцесс (БСП)

TurboConf ИР адаптер 1.63