РазрешитьРаботуСВнешнимиРесурсами (БСП)

Автор: 1С
ОбщийМодуль.БлокировкаРаботыСВнешнимиРесурсами
БСП

Разрешить работу внешними ресурсами.

Процедура РазрешитьРаботуСВнешнимиРесурсами() Экспорт
	
	НачатьТранзакцию();
	Попытка
		ЗаблокироватьДанныеПараметровБлокировки();
		
		ПараметрыБлокировки = СохраненныеПараметрыБлокировки();
		ВключитьОтключенныеРегламентныеЗадания(ПараметрыБлокировки);
		
		ПараметрыБлокировки = ТекущиеПараметрыБлокировки();
		СохранитьПараметрыБлокировки(ПараметрыБлокировки);
		
		Если ОбщегоНазначения.ИнформационнаяБазаФайловая() Тогда
			ЗаписатьИдентификаторФайловойБазыВФайлПроверки(ПараметрыБлокировки.ИдентификаторБазы);
		КонецЕсли;
		
		ЗафиксироватьТранзакцию();
	Исключение
		ОтменитьТранзакцию();
		ВызватьИсключение;
	КонецПопытки;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.Обсуждения") Тогда
		МодульОбсужденияСлужебный = ОбщегоНазначения.ОбщийМодуль("ОбсужденияСлужебный");
		МодульОбсужденияСлужебный.Разблокировать();
	КонецЕсли;
	
	ПараметрыСеанса.РаботаСВнешнимиРесурсамиЗаблокирована = Ложь;
	
	ОбновитьПовторноИспользуемыеЗначения();
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

РазблокироватьРаботуСВнешнимиРесурсами (БСП)

ЗаблокироватьРаботуСВнешнимиРесурсами (БСП)

РаботаСВнешнимиРесурсамиЗаблокирована (БСП)

ЗапретитьРаботуСВнешнимиРесурсами (БСП)

ОбновитьПараметрыБлокировкиРаботыСВнешнимиРесурсами (БСП)

ПоказатьФормуБлокировкиРаботыСВнешнимиРесурсами (БСП)

ПослеЗавершенияЗапросаРазрешенийНаИспользованиеВнешнихРесурсов (БСП)

ПослеОткрытияОкнаБлокировкиРаботыСВнешнимиРесурсами (БСП)

TurboConf - расширение Конфигуратора 1С